Reporting Services Error User cannot be found

In case of SSRS  in SharePoint Integrated mode.
You may have report server in SharePoint integrated mode and the Reporting services running under domain account. which will be part of domain admin group as well.but when you try to connect to http:\\localhost\reportserver it may give following  error:
Reporting Services Error
--------------------------------------------------------------------------------
Report Server has encountered a SharePoint error. (rsSharePointError) Get Online Help
User cannot be found.
--------------------------------------------------------------------------------
SQL Server Reporting Services

and in reporting service log it gives me following information
w3wp!webserver!1!8/15/2007-13:40:01:: e ERROR: Reporting Services error Microsoft.ReportingServices.Diagnostics.Utilities.SharePointException: Report Server has encountered a SharePoint error. ---> Microsoft.SharePoint.SPException: User cannot be found.
at Microsoft.SharePoint.SPUserCollection.GetByID(Int32 id)
at Microsoft.SharePoint.SPWeb.get_Author()
at Microsoft.ReportingServices.SharePoint.Server.Utility.GetSPWebProperties(SPWeb web)
at Microsoft.ReportingServices.SharePoint.Server.SharePointDBInterface.internalFindObjectsNonRecursive(String wssUrl, CatalogItemList& children)
at Microsoft.ReportingServices.SharePoint.Server.SharePointDBInterface.FindObjectsNonRecursive(String wssUrl, CatalogItemList& childList, Security secMgr, IPathTranslator pathTranslator, Boolean appendMyReports)
--- End of inner exception stack trace ---
at Microsoft.ReportingServices.SharePoint.Server.SharePointDBInterface.FindObjectsNonRecursive(String wssUrl, CatalogItemList& childList, Security secMgr, IPathTranslator pathTranslator, Boolean appendMyReports)
at Microsoft.ReportingServices.Library.ListChildrenAction.PerformActionNow()
at Microsoft.ReportingServices.Library.RSSoapAction`1.Execute()
at Microsoft.ReportingServices.WebServer.ReportServiceHttpHandler.RenderFolder()
at Microsoft.ReportingServices.WebServer.ReportService

Suggestion:

You need to try  upgrading the report server on the Report server configuration option .It might be the case that it requires manual upgrading as you might have installed SP2 which did not upgrade it to new share point integrated mode.

Comments